Organize Series CPT Support Changelog

This entry is part 2 of 3 in the series Organize Series CPT Support Setup

= 0.1 =

  • Initial release of addon
Series NavigationOrganize Series CPT Support – InstallationOrganize Series CPT Support FAQ

6 comments

  1. Jason Pelker

    Upon activation in multisite (either network-wide or for a single site), the Organize Series Addon: Custom Post Type Support plugin causes a plugin update notification in both the admin bar and the plugin menu:

    https://www.evernote.com/shard/s1/sh/433088f1-c171-4f3c-b7e6-d1925a005265/d32c59c4aa504a4e865f827615149a59

    https://www.evernote.com/shard/s1/sh/7f702e55-30dc-44ce-b82c-616ad110ac6d/730df490f1bb9fd35d016e9dc91e06d4

    I’ve been trying to research where this issue might come from for weeks until today, I finally copied my site to a test server so I could properly experiment with the plugin folder.

    I can’t imagine why your plugin behaves this way (since I was unable to find any articles that mention a similar issue with any other plugins, I have to infer that this is a very rare occurrence), so you may want to test it and hopefully, release a bug fix.

    I also ran some tests on a non-multisite WordPress installation.

    If the Organize Series Addon: Custom Post Type Support plugin is first activated without the parent Organize Series plugin first being activated, there is a warning message that displays, reading, “There is an update to the Organize Series Addon: Custom Post Type Support plugin. Please set the API key to download” even though there isn’t actually an update available (the plugin sits at version 0.1 on both the download page here and on the WordPress updates page).

    I have a feeling this error message has something to do with the issue. I can’t get the update notification to reshow, though, even if I deactivate the Organize Series plugin or remove the API from the options (or both) so you’ll want to run this experiment with a fresh install of WordPress to see the message.

    Either way, the omni-present update notification on multisite should probably be considered a bug.

Leave a Reply